What’s Vulnerable › Vulnerabilities
CVE-2025-5490: Football Pool <= 2.12.4 - Authenticated (Administrator+) Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-19 · updated 2026-06-17
- Weakness: CWE-79
Description
The Football Pool plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 2.12.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Affected products
- AntoineH Football Pool: before 2.12.5 — fixed in 2.12.5
How to fix
Upgrade to a fixed version: AntoineH Football Pool 2.12.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3313611%40football-pool&new=3313611%40football-pool&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/football-pool/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/16a285b1-7a20-455f-8f74-2e468dd436d3?source=cve
Get alerted when CVE-2025-5490 or the next vulnerability affects your stack