What’s Vulnerable › Vulnerabilities
CVE-2025-54956
- Severity: low (CVSS 3.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-03 · updated 2026-06-17
- Weakness: CWE-669
Description
The gh package before 1.5.0 for R delivers an HTTP response in a data structure that includes the Authorization header from the corresponding HTTP request.
Affected products
- r-lib gh: before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: r-lib gh 1.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/r-lib/gh/commit/b575d488c71318449cc6c8c989c617db29275848
- https://github.com/r-lib/gh/compare/v1.4.1...v1.5.0
- https://github.com/r-lib/gh/issues/222
- https://lists.debian.org/debian-lts-announce/2025/11/msg00021.html
Get alerted when CVE-2025-54956 or the next vulnerability affects your stack