What’s Vulnerable › Vulnerabilities
CVE-2025-54964
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-23 · updated 2026-06-17
- Weakness: CWE-77
Description
An issue was discovered in BAE SOCET GXP before 4.6.0.2. An attacker with the ability to interact with the GXP Job Service may inject arbitrary executables. If the Job Service is configured for local-only access, this may allow for privilege escalation in certain situations. If the Job Service is network accessible, this may allow remote command execution.
Affected products
- Baesystems Socet Gxp: before 4.6.0.2 — fixed in 4.6.0.2
How to fix
Upgrade to a fixed version: Baesystems Socet Gxp 4.6.0.2. Check the vendor advisory for mitigations.
References
- https://www.baesystems.com/en-us/product/geospatial-exploitation-products
- https://www.geospatialexploitationproducts.com/content/socet-gxp/vulnerabilities-disclosure/#cve-2025-54964
Get alerted when CVE-2025-54964 or the next vulnerability affects your stack