What’s Vulnerable › Vulnerabilities
CVE-2025-5498: slackero phpwcms Custom Source Tab cnt21.readform.inc.php is_file deserialization
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-03 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability was found in slackero phpwcms up to 1.9.45/1.10.8. It has been rated as critical. This issue affects the function file_get_contents/is_file of the file include/inc_lib/content/cnt21.readform.inc.php of the component Custom Source Tab. The manipulation of the argument cpage_custom leads to deserialization. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.9.46 and 1.10.9 is able to address this issue. It is recommended to upgrade the affected component.
Affected products
- slackero phpwcms: before 1.9.46; from 1.10.2 before 1.10.9 — fixed in 1.10.9, 1.9.46
How to fix
Upgrade to a fixed version: slackero phpwcms 1.10.9, 1.9.46. Check the vendor advisory for mitigations.
References
- https://github.com/3em0/cve_repo/blob/main/phpwcms/cnt21.readform.inc.php%23file_get_contents.md
- https://github.com/3em0/cve_repo/blob/main/phpwcms/cnt21.readform.inc.php%23is_file.md
- https://github.com/slackero/phpwcms/releases/tag/v1.10.9
- https://vuldb.com/?ctiid.310913
- https://vuldb.com/?id.310913
- https://vuldb.com/?submit.578054
- https://vuldb.com/?submit.578055
Get alerted when CVE-2025-5498 or the next vulnerability affects your stack