What’s Vulnerable › Vulnerabilities

CVE-2025-54988: Apache Tika PDF parser module: XXE vulnerability in PDFParser's handling of XFA

Description

Critical XXE in Apache Tika (tika-parser-pdf-module) in Apache Tika 1.13 through and including 3.2.1 on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. An attacker may be able to read sensitive data or trigger malicious requests to internal resources or third-party servers. Note that the tika-parser-pdf-module is used as a dependency in several Tika packages including at least: tika-parsers-standard-modules, tika-parsers-standard-package, tika-app, tika-grpc and tika-server-standard. Users are recommended to upgrade to version 3.2.2, which fixes this issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Tika 3.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-54988 or the next vulnerability affects your stack