What’s Vulnerable › Vulnerabilities
CVE-2025-5499: slackero phpwcms image_resized.php getimagesize deserialization
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-03 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability classified as critical has been found in slackero phpwcms up to 1.9.45/1.10.8. Affected is the function is_file/getimagesize of the file image_resized.php. The manipulation of the argument imgfile leads to deserialization. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.9.46 and 1.10.9 is able to address this issue. It is recommended to upgrade the affected component.
Affected products
- slackero phpwcms: before 1.9.46; from 1.10.2 before 1.10.9 — fixed in 1.10.9, 1.9.46
How to fix
Upgrade to a fixed version: slackero phpwcms 1.10.9, 1.9.46. Check the vendor advisory for mitigations.
References
- https://github.com/3em0/cve_repo/blob/main/phpwcms/image_resized%23getimagesize.md
- https://github.com/slackero/phpwcms/releases/tag/v1.10.9
- https://vuldb.com/?ctiid.310914
- https://vuldb.com/?id.310914
- https://vuldb.com/?submit.578082
- https://vuldb.com/?submit.578083
Get alerted when CVE-2025-5499 or the next vulnerability affects your stack