What’s Vulnerable › Vulnerabilities
CVE-2025-54996: OpenBao Root Namespace Operator May Elevate Token Privileges
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-09 · updated 2026-06-17
- Weakness: CWE-269
Description
OpenBao exists to provide a software solution to manage, store, and distribute sensitive data including secrets, certificates, and keys. In versions 2.3.1 and below, accounts with access to highly-privileged identity entity systems in root namespaces were able to increase their scope directly to the root policy. While the identity system allowed adding arbitrary policies, which in turn could contain capability grants on arbitrary paths, the root policy was restricted to manual generation using unseal or recovery key shares. The global root policy was not accessible from child namespaces. This issue is fixed in version 2.3.2. To workaround this vulnerability, use of denied_parameters in any policy which has access to the affected identity endpoints (on identity entities) may be sufficient to prohibit this type of attack.
Affected products
- openbao: before 2.3.2 — fixed in 2.3.2
How to fix
Upgrade to a fixed version: openbao 2.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/openbao/openbao/pull/1627
- https://github.com/openbao/openbao/releases/tag/v2.3.2
- https://github.com/openbao/openbao/security/advisories/GHSA-vf84-mxrq-crqc
Get alerted when CVE-2025-54996 or the next vulnerability affects your stack