What’s Vulnerable › Vulnerabilities
CVE-2025-54997: OpenBao: Privileged Operator May Execute Code on the Underlying Host
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-09 · updated 2026-06-17
- Weakness: CWE-94
Description
OpenBao exists to provide a software solution to manage, store, and distribute sensitive data including secrets, certificates, and keys. In versions 2.3.1 and below, some OpenBao deployments intentionally limit privileged API operators from executing system code or making network connections. However, these operators can bypass both restrictions through the audit subsystem by manipulating log prefixes. This allows unauthorized code execution and network access that violates the intended security model. This issue is fixed in version 2.3.2. To workaround, users can block access to sys/audit/* endpoints using explicit deny policies, but root operators cannot be restricted this way.
Affected products
- openbao: before 2.3.2 — fixed in 2.3.2
How to fix
Upgrade to a fixed version: openbao 2.3.2. Check the vendor advisory for mitigations.
References
- https://discuss.hashicorp.com/t/hcsec-2025-14-privileged-vault-operator-may-execute-code-on-the-underlying-host/76033
- https://github.com/openbao/openbao/pull/1634
- https://github.com/openbao/openbao/releases/tag/v2.3.2
- https://github.com/openbao/openbao/security/advisories/GHSA-xp75-r577-cvhp
Get alerted when CVE-2025-54997 or the next vulnerability affects your stack