What’s Vulnerable › Vulnerabilities
CVE-2025-55004: ImageMagick: heap-buffer overflow read in MNG magnification with alpha
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-13 · updated 2026-06-17
- Weakness: CWE-122
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to version 7.1.2-1, ImageMagick is vulnerable to heap-buffer overflow read around the handling of images with separate alpha channels when performing image magnification in ReadOneMNGIMage. This can likely be used to leak subsequent memory contents into the output image. This issue has been patched in version 7.1.2-1.
Affected products
- ImageMagick: before 7.1.2-1 — fixed in 7.1.2-1
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-1. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-cjc8-g9w8-chfw
- https://goo.gle/bigsleep
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-cjc8-g9w8-chfw
Get alerted when CVE-2025-55004 or the next vulnerability affects your stack