What’s Vulnerable › Vulnerabilities
CVE-2025-55005: ImageMagick: heap-buffer overflow in log colorspace handling
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-13 · updated 2026-06-17
- Weakness: CWE-122
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to version 7.1.2-1, when preparing to transform from Log to sRGB colorspaces, the logmap construction fails to handle cases where the reference-black or reference-white value is larger than 1024. This leads to corrupting memory beyond the end of the allocated logmap buffer. This issue has been patched in version 7.1.2-1.
Affected products
- ImageMagick: before 7.1.2-1 — fixed in 7.1.2-1
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-1. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-v393-38qx-v8fp
- https://goo.gle/bigsleep
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-v393-38qx-v8fp
Get alerted when CVE-2025-55005 or the next vulnerability affects your stack