What’s Vulnerable › Vulnerabilities
CVE-2025-55007: Knowage vulnerable to server-side request forgery
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-01 · updated 2026-06-17
- Weakness: CWE-918
Description
Knowage is an open source analytics and business intelligence suite. Prior to version 8.1.37, Knowage is vulnerable to server-side request forgery. The vulnerability allows attackers to send requests to arbitrary hosts/paths. Since the attacker is not able to read the response, the impact of this vulnerability is limited. However, an attacker could be able to leverage this vulnerability to scan the internal network. This issue has been patched in version 8.1.37.
Affected products
- KnowageLabs Knowage-Server: before 8.1.37 — fixed in 8.1.37
How to fix
Upgrade to a fixed version: KnowageLabs Knowage-Server 8.1.37. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-55007 or the next vulnerability affects your stack