What’s Vulnerable › Vulnerabilities
CVE-2025-55010: Kanboard Authenticated Admin Remote Code Execution via Unsafe Deserialization of Events
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-12 · updated 2026-06-17
- Weakness: CWE-502
Description
Kanboard is project management software that focuses on the Kanban methodology. Prior to version 1.2.47, an unsafe deserialization vulnerability in the ProjectEventActvityFormatter allows admin users the ability to instantiate arbitrary php objects by modifying the event["data"] field in the project_activities table. A malicious actor can update this field to use a php gadget to write a web shell into the /plugins folder, which then gives remote code execution on the host system. This issue has been patched in version 1.2.47.
Affected products
- kanboard: before 1.2.47 — fixed in 1.2.47
How to fix
Upgrade to a fixed version: kanboard 1.2.47. Check the vendor advisory for mitigations.
References
- https://github.com/kanboard/kanboard/blob/b033c0e0f982f8158e240bce8ab54c29727f8efe/app/Formatter/ProjectActivityEventFormatter.php#L43-L57
- https://github.com/kanboard/kanboard/commit/7148ac092e5db6b33e0fc35e04bca328d96c1f6f
- https://github.com/kanboard/kanboard/security/advisories/GHSA-359x-c69j-q64r
- https://github.com/kanboard/kanboard/security/advisories/GHSA-359x-c69j-q64r
Get alerted when CVE-2025-55010 or the next vulnerability affects your stack