What’s Vulnerable › Vulnerabilities

CVE-2025-55017: Apache IoTDB: Path Traversal Vulnerability

Description

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache IoTDB. This issue affects Apache IoTDB: from 2.0.0 before 2.0.6, from 1.0.0 before 1.3.6. Users are recommended to upgrade to version 1.3.6 and 2.0.6, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache IoTDB 1.3.6, 2.0.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-55017 or the next vulnerability affects your stack