What’s Vulnerable › Vulnerabilities
CVE-2025-55094: Potential out-of-bounds read in _nx_icmpv6_validate_options()
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-17 · updated 2026-10-09
- Weakness: CWE-125
Description
In NetX Duo before 6.4.4, the networking support module for Eclipse Foundation ThreadX, there was a potential out of bound read issue in _nx_icmpv6_validate_options() when handling a packet with ICMP6 options.
Affected products
- Eclipse Foundation NetX Duo: before 6.4.4.202503 — fixed in 6.4.4.202503
How to fix
Upgrade to a fixed version: Eclipse Foundation NetX Duo 6.4.4.202503. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-55094 or the next vulnerability affects your stack