What’s Vulnerable › Vulnerabilities
CVE-2025-55130
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-20 · updated 2026-07-15
- Weakness: CWE-289
Description
A flaw in Node.js’s Permissions model allows attackers to bypass `--allow-fs-read` and `--allow-fs-write` restrictions using crafted relative symlink paths. By chaining directories and symlinks, a script granted access only to the current directory can escape the allowed path and read sensitive files. This breaks the expected isolation guarantees and enables arbitrary file read/write, leading to potential system compromise. This vulnerability affects users of the permission model on Node.js v20, v22, v24, and v25.
Affected products
- Node.js: from 20.0.0 before 20.20.0; from 22.0.0 before 22.22.0; from 24.0.0 before 24.13.0; from 25.0.0 before 25.3.0 — fixed in 20.20.0, 22.22.0, 24.13.0, 25.3.0
How to fix
Upgrade to a fixed version: Node.js 20.20.0, 22.22.0, 24.13.0, 25.3.0. Check the vendor advisory for mitigations.
References
- https://nodejs.org/en/blog/vulnerability/december-2025-security-releases
- https://access.redhat.com/errata/RHSA-2026:1842
- https://access.redhat.com/errata/RHSA-2026:1843
- https://access.redhat.com/errata/RHSA-2026:2420
- https://access.redhat.com/errata/RHSA-2026:2421
- https://access.redhat.com/errata/RHSA-2026:2422
- https://access.redhat.com/errata/RHSA-2026:2767
- https://access.redhat.com/errata/RHSA-2026:2768
- https://access.redhat.com/errata/RHSA-2026:2781
- https://access.redhat.com/errata/RHSA-2026:2782
- https://access.redhat.com/errata/RHSA-2026:2783
- https://access.redhat.com/errata/RHSA-2026:2864
Get alerted when CVE-2025-55130 or the next vulnerability affects your stack