What’s Vulnerable › Vulnerabilities
CVE-2025-55132
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-20 · updated 2026-06-17
- Weakness: CWE-276
Description
A flaw in Node.js's permission model allows a file's access and modification timestamps to be changed via `futimes()` even when the process has only read permissions. Unlike `utimes()`, `futimes()` does not apply the expected write-permission checks, which means file metadata can be modified in read-only directories. This behavior could be used to alter timestamps in ways that obscure activity, reducing the reliability of logs. This vulnerability affects users of the permission model on Node.js v20, v22, v24, and v25.
Affected products
- Node.js: from 20.0.0 before 20.20.0; from 22.0.0 before 22.22.0; from 24.0.0 before 24.13.0; from 25.0.0 before 25.3.0 — fixed in 20.20.0, 22.22.0, 24.13.0, 25.3.0
How to fix
Upgrade to a fixed version: Node.js 20.20.0, 22.22.0, 24.13.0, 25.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-55132 or the next vulnerability affects your stack