What’s Vulnerable › Vulnerabilities
CVE-2025-55151: Stirling-PDF SSRF vulnerability on /api/v1/convert/file/pdf
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-11 · updated 2026-06-17
- Weakness: CWE-918
Description
Stirling-PDF is a locally hosted web application that performs various operations on PDF files. Prior to version 1.1.0, the "convert file to pdf" functionality (/api/v1/convert/file/pdf) uses LibreOffice's unoconvert tool for conversion, and SSRF vulnerabilities exist during the conversion process. This issue has been patched in version 1.1.0.
Affected products
- Stirling-Tools Stirling-PDF: before 1.1.0 — fixed in 1.1.0
How to fix
Upgrade to a fixed version: Stirling-Tools Stirling-PDF 1.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/Stirling-Tools/Stirling-PDF/commit/7d6b70871bad2a3ff810825f7382c49f55293943
- https://github.com/Stirling-Tools/Stirling-PDF/security/advisories/GHSA-76hv-h7g2-xfv3
Get alerted when CVE-2025-55151 or the next vulnerability affects your stack