What’s Vulnerable › Vulnerabilities
CVE-2025-55157: Vim heap use-after-free vulnerability when processing recursive tuple data types
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-11 · updated 2026-06-17
- Weakness: CWE-416
Description
Vim is an open source, command line text editor. In versions from 9.1.1231 to before 9.1.1400, When processing nested tuples in Vim script, an error during evaluation can trigger a use-after-free in Vim’s internal tuple reference management. Specifically, the tuple_unref() function may access already freed memory due to improper lifetime handling, leading to memory corruption. The exploit requires direct user interaction, as the script must be explicitly executed within Vim. This issue has been patched in version 9.1.1400.
Affected products
- vim/vim: from 9.1.1231 before 9.1.1400 — fixed in 9.1.1400
How to fix
Upgrade to a fixed version: vim/vim 9.1.1400. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/1307743697bbc46e1518abfea7f89caa95bcaf97
- https://github.com/vim/vim/releases/tag/v9.1.1400
- https://github.com/vim/vim/security/advisories/GHSA-3r4f-mm4w-wgg6
Get alerted when CVE-2025-55157 or the next vulnerability affects your stack