What’s Vulnerable › Vulnerabilities
CVE-2025-55158: Vim double-free vulnerability during Vim9 script import operations
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-11 · updated 2026-06-17
- Weakness: CWE-415
Description
Vim is an open source, command line text editor. In versions from 9.1.1231 to before 9.1.1406, when processing nested tuples during Vim9 script import operations, an error during evaluation can trigger a double-free in Vim’s internal typed value (typval_T) management. Specifically, the clear_tv() function may attempt to free memory that has already been deallocated, due to improper lifetime handling in the handle_import / ex_import code paths. The vulnerability can only be triggered if a user explicitly opens and executes a specially crafted Vim script. This issue has been patched in version 9.1.1406.
Affected products
- vim/vim: from 9.1.1231 before 9.1.1406 — fixed in 9.1.1406
How to fix
Upgrade to a fixed version: vim/vim 9.1.1406. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/9772025d24e939fd84b85748ce35c26874c05775
- https://github.com/vim/vim/releases/tag/v9.1.1406
- https://github.com/vim/vim/security/advisories/GHSA-5fg8-wvx3-583x
Get alerted when CVE-2025-55158 or the next vulnerability affects your stack