What’s Vulnerable › Vulnerabilities
CVE-2025-55162: Envoy: oAuth2 Filter Signout route will not clear cookies because of missing "secure;" flag
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-03 · updated 2026-06-17
- Weakness: CWE-613
Description
Envoy is an open source L7 proxy and communication bus designed for large modern service oriented architectures. In versions below 1.32.10 and 1.33.0 through 1.33.6, 1.34.0 through 1.34.4 and 1.35.0, insufficient Session Expiration in the Envoy OAuth2 filter leads to failed logout operations. When configured with __Secure- or __Host- prefixed cookie names, the filter fails to append the required Secure attribute to the Set-Cookie header during deletion. Modern browsers ignore this invalid request, causing the session cookie to persist. This allows a user to remain logged in after they believe they have logged out, creating a session hijacking risk on shared computers. The current implementation iterates through the configured cookie names to generate deletion headers but does not check for these prefixes. This failure to properly construct the deletion header means the user's session cookies are never removed by the browser, leaving the session active and allowing the next user of the same browser to gain unauthorized access to the original user's account and data. This is fixed in versions 1.32.10, 1.33.7, 1.34.5 and 1.35.1.
Affected products
- envoyproxy envoy: before 1.32.10; from 1.33.0 through 1.33.7; from 1.34.0 before 1.34.5; 1.35.0 — fixed in 1.32.10, 1.34.5
How to fix
Upgrade to a fixed version: envoyproxy envoy 1.32.10, 1.34.5. Check the vendor advisory for mitigations.
References
- https://github.com/envoyproxy/envoy/releases/tag/v1.35.1
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-95j4-hw7f-v2rh
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-95j4-hw7f-v2rh
Get alerted when CVE-2025-55162 or the next vulnerability affects your stack