What’s Vulnerable › Vulnerabilities
CVE-2025-55164: content-security-policy-parser Prototype Pollution Vulnerability May Lead to RCE
- Severity: high (CVSS 8.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-12 · updated 2026-06-17
- Weakness: CWE-1321
Description
content-security-policy-parser parses content security policy directives. A prototype pollution vulnerability exists in versions 0.5.0 and earlier, wherein if a policy name is called __proto__, one can override the Object prototype. This issue has been patched in version 0.6.0. A workaround involves disabling prototype method in NodeJS, neutralizing all possible prototype pollution attacks. Provide either --disable-proto=delete (recommended) or --disable-proto=throw as an argument to node to enable this feature.
Affected products
- helmetjs content-security-policy-parser: before 0.6.0
References
- https://github.com/helmetjs/content-security-policy-parser/commit/b13a52554f0168af393e3e38ed4a94e9e6aea9dc
- https://github.com/helmetjs/content-security-policy-parser/issues/11
- https://github.com/helmetjs/content-security-policy-parser/security/advisories/GHSA-w2cq-g8g3-gm83
- https://www.vicarius.io/vsociety/posts/cve-2025-55164-detect-node-csp-parser-vulnerability
- https://www.vicarius.io/vsociety/posts/cve-2025-55164-mitigate-csp-parser-vulnerability
Get alerted when CVE-2025-55164 or the next vulnerability affects your stack