What’s Vulnerable › Vulnerabilities
CVE-2025-55173: Next.js Content Injection Vulnerability for Image Optimization
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-29 · updated 2026-10-18
- Weakness: CWE-20
Description
Next.js is a React framework for building full-stack web applications. In versions before 14.2.31 and from 15.0.0 to before 15.4.5, Next.js Image Optimization is vulnerable to content injection. The issue allowed attacker-controlled external image sources to trigger file downloads with arbitrary content and filenames under specific configurations. This behavior could be abused for phishing or malicious file delivery. This vulnerability has been fixed in Next.js versions 14.2.31 and 15.4.5.
Affected products
- Next.js: before 14.2.31; from 15.0.0 before 15.4.5 — fixed in 14.2.31, 15.4.5
- Npm Next: from 0.9.9 before 14.2.31; from 15.0.0 before 15.4.5 — fixed in 14.2.31, 15.4.5
How to fix
Upgrade to a fixed version: Next.js 14.2.31, 15.4.5; Npm Next 14.2.31, 15.4.5. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/next.js/commit/6b12c60c61ee80cb0443ccd20de82ca9b4422ddd
- https://github.com/vercel/next.js/security/advisories/GHSA-xv57-4mr9-wg8v
- https://vercel.com/changelog/cve-2025-55173
Get alerted when CVE-2025-55173 or the next vulnerability affects your stack