What’s Vulnerable › Vulnerabilities
CVE-2025-55177: Meta Platforms WhatsApp Incorrect Authorization Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2025-09-02
- EPSS: 13.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-29 · updated 2026-10-18
- Weakness: CWE-863
Description
Incomplete authorization of linked device synchronization messages in WhatsApp for iOS prior to v2.25.21.73, WhatsApp Business for iOS v2.25.21.78, and WhatsApp for Mac v2.25.21.78 could have allowed an unrelated user to trigger processing of content from an arbitrary URL on a target’s device. We assess that this vulnerability, in combination with an OS-level vulnerability on Apple platforms (CVE-2025-43300), may have been exploited in a sophisticated attack against specific targeted users.
Affected products
- Facebook WhatsApp for Android: from 2.22.25.2 before 2.25.21.73; from 2.22.25.2 before 2.25.21.78 — fixed in 2.25.21.73, 2.25.21.78
- Whatsapp Business: from 2.22.25.2 before 2.25.21.78 — fixed in 2.25.21.78
How to fix
Upgrade to a fixed version: Facebook WhatsApp for Android 2.25.21.73, 2.25.21.78; Whatsapp Business 2.25.21.78. Check the vendor advisory for mitigations.
References
- https://www.facebook.com/security/advisories/cve-2025-55177
- https://www.whatsapp.com/security/advisories/2025/
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-55177
Get alerted when CVE-2025-55177 or the next vulnerability affects your stack