What’s Vulnerable › Vulnerabilities
CVE-2025-55182: Meta React Server Components Remote Code Execution Vulnerability
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2025-12-05
- EPSS: 99.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-03 · updated 2026-10-18
- Weakness: CWE-502
Description
A pre-authentication remote code execution vulnerability exists in React Server Components versions 19.0.0, 19.1.0, 19.1.1, and 19.2.0 including the following packages: react-server-dom-parcel, react-server-dom-turbopack, and react-server-dom-webpack. The vulnerable code unsafely deserializes payloads from HTTP requests to Server Function endpoints.
Affected products
- React: 19.0.0, 19.1.0, 19.1.1, 19.2.0
- Next.js: from 15.0.0 before 15.0.5; from 15.1.0 before 15.1.9; from 15.2.0 before 15.2.6; from 15.3.0 before 15.3.6; from 15.4.0 before 15.4.8; from 15.5.0 before 15.5.7 — fixed in 15.0.5, 15.1.9, 15.2.6, 15.3.6, 15.4.8, 15.5.7
How to fix
Upgrade to a fixed version: Next.js 15.0.5, 15.1.9, 15.2.6, 15.3.6. Check the vendor advisory for mitigations.
References
- https://react.dev/blog/2025/12/03/critical-security-vulnerability-in-react-server-components
- https://www.facebook.com/security/advisories/cve-2025-55182
- http://www.openwall.com/lists/oss-security/2025/12/03/4
- https://news.ycombinator.com/item?id=46136026
- https://aws.amazon.com/blogs/security/china-nexus-cyber-threat-groups-rapidly-exploit-react2shell-vulnerability-cve-2025-55182/
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-55182
Get alerted when CVE-2025-55182 or the next vulnerability affects your stack