What’s Vulnerable › Vulnerabilities
CVE-2025-55193: Active Record logging vulnerable to ANSI escape injection
- Severity: low (CVSS 2.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-13 · updated 2026-06-17
- Weakness: CWE-150
Description
Active Record connects classes to relational database tables. Prior to versions 7.1.5.2, 7.2.2.2, and 8.0.2.1, the ID passed to find or similar methods may be logged without escaping. If this is directly to the terminal it may include unescaped ANSI sequences. This issue has been patched in versions 7.1.5.2, 7.2.2.2, and 8.0.2.1.
Affected products
- Rubygems Activerecord: from 8.0 before 8.0.2.1; from 7.2 before 7.2.2.2; before 7.1.5.2; 8.0.0, 8.0.0.1, 8.0.1, 8.0.2, 7.2.0, 7.2.1 (+484) — fixed in 8.0.2.1, 7.2.2.2, 7.1.5.2
- Ruby on Rails: from 0, < 7.1.5.2; from 7.2, < 7.2.2.2; from 8.0, < 8.0.2.1
How to fix
Upgrade to a fixed version: Rubygems Activerecord 8.0.2.1, 7.2.2.2, 7.1.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/rails/rails/commit/3beef20013736fd52c5dcfdf061f7999ba318290
- https://github.com/rails/rails/commit/568c0bc2f1e74c65d150a84b89a080949bf9eb9b
- https://github.com/rails/rails/commit/6a944ca4805e72050a0fbb1a461534eb760d3202
- https://github.com/rails/rails/security/advisories/GHSA-76r7-hhxj-r776
Get alerted when CVE-2025-55193 or the next vulnerability affects your stack