What’s Vulnerable › Vulnerabilities
CVE-2025-55198: Helm May Panic Due To Incorrect YAML Content
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-14 · updated 2026-06-17
- Weakness: CWE-908
Description
Helm is a package manager for Charts for Kubernetes. Prior to version 3.18.5, when parsing Chart.yaml and index.yaml files, an improper validation of type error can lead to a panic. This issue has been resolved in Helm 3.18.5. A workaround involves ensuring YAML files are formatted as Helm expects prior to processing them with Helm.
Affected products
- helm: before 3.18.5 — fixed in 3.18.5
How to fix
Upgrade to a fixed version: helm 3.18.5. Check the vendor advisory for mitigations.
References
- https://github.com/helm/helm/commit/ec5f59e2db56533d042a124f5bae54dd87b558e6
- https://github.com/helm/helm/security/advisories/GHSA-f9f8-9pmf-xv68
Get alerted when CVE-2025-55198 or the next vulnerability affects your stack