What’s Vulnerable › Vulnerabilities
CVE-2025-55202: Opencast has a partial path traversal vulnerability in UI config
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-29 · updated 2026-10-19
- Weakness: CWE-23
Description
Opencast is a free, open-source platform to support the management of educational audio and video content. In version 18.0 and versions before 17.7, the protections against path traversal attacks in the UI config module are insufficient, still partially allowing for attacks in very specific cases. The path is checked without checking for the file separator. This could allow attackers access to files within another folder which starts with the same path. This issue has been fixed in versions 17.7 and 18.1. To mitigate this issue, check for folders that start with the same path as the ui-config folder.
Affected products
- opencast: before 17.7; 18.0 — fixed in 17.7
How to fix
Upgrade to a fixed version: opencast 17.7. Check the vendor advisory for mitigations.
References
- https://github.com/opencast/opencast/commit/e2cc65d6fbe052ebb71d9f6b583bb54b181af009
- https://github.com/opencast/opencast/pull/6979
- https://github.com/opencast/opencast/security/advisories/GHSA-hq8m-v68g-8cf8
Get alerted when CVE-2025-55202 or the next vulnerability affects your stack