What’s Vulnerable › Vulnerabilities
CVE-2025-55209: FreePBX UCP is Vulnerable to Stored XSS Through its User Control Panel
- Severity: medium (CVSS 5.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-04 · updated 2026-06-17
- Weakness: CWE-79
Description
contactmanager is a module for FreePBX@, which is an open source GUI that controls and manages Asterisk© (PBX). In versions 15.0.14 and below, 16.0.0 through 16.0.26.4 and 17.0.0 through 17.0.5, a stored cross-site scripting (XSS) vulnerability in FreePBX allows a low-privileged User Control Panel (UCP) user to inject malicious JavaScript into the system. The malicious code executes in the context of an administrator when they interact with the affected component, leading to session hijacking and potential privilege escalation. This issue is fixed in versions 15.0.14, 16.0.27 and 17.0.6.
Affected products
- FreePBX contactmanager: before 15.0.14; from 16.0.0, < 16.0.27; from 17.0.0, < 17.0.6
References
- https://github.com/FreePBX/contactmanager/commit/55abba0f1ab5d66ba87732fd06179231d1f68184
- https://github.com/FreePBX/security-reporting/security/advisories/GHSA-j654-x3q2-6wm3
Get alerted when CVE-2025-55209 or the next vulnerability affects your stack