What’s Vulnerable › Vulnerabilities
CVE-2025-55210: FreePBX API has a Privilege Escalation Error in GraphQL Allowing Authenticated Users to Access Additional Scopes
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-12 · updated 2026-06-17
- Weakness: CWE-270
Description
FreePBX is an open-source web-based graphical user interface (GUI) that manages Asterisk. Prior to 17.0.5 and 16.0.17, FreePBX module api (PBX API) is vulnerable to privilege escalation by authenticated users with REST/GraphQL API access. This vulnerability allows an attacker to forge a valid JWT with full access to the REST and GraphQL APIs on a FreePBX that they've already connected to, possibly as a lower privileged user. The JWT is signed using the api-oauth.key private key. An attacker can generate their own token if they possess this key (e.g., by accessing an affected instance), and specify any scopes they wish (e.g., rest, gql), bypassing traditional authorization checks. However, FreePBX enforces that the jti (JWT ID) claim must exist in the database (api_access_tokens table in the asterisk MySQL database) in order for the token to be accepted. Therefore, the attacker must know a jti value that already exists on the target instance. This vulnerability is fixed in 17.0.5 and 16.0.17.
Affected products
- Sangoma FreePBX: from 16.0.2 before 16.0.17; from 17.0.1 before 17.0.5 — fixed in 16.0.17, 17.0.5
How to fix
Upgrade to a fixed version: Sangoma FreePBX 16.0.17, 17.0.5. Check the vendor advisory for mitigations.
References
- https://github.com/FreePBX/api/commit/bc6f7d72063cffb18babb6559fa351046d7ad19b
- https://github.com/FreePBX/api/commit/c16a3a79b83382fb4884e51174882ed635637002
- https://github.com/FreePBX/api/commit/d66786634e7e7d3eedcb4d0931b32c415ba6e9ef
- https://github.com/FreePBX/security-reporting/security/advisories/GHSA-gvgh-p7wj-76cf
Get alerted when CVE-2025-55210 or the next vulnerability affects your stack