What’s Vulnerable › Vulnerabilities
CVE-2025-55211: FreePBX Post-Authenticated Command Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-15 · updated 2026-06-17
- Weakness: CWE-78
Description
FreePBX is an open-source web-based graphical user interface. From 17.0.19.11 to before 17.0.21, authenticated users of the Administrator Control Panel (ACP) can run arbitrary shell commands by maliciously changing languages of the framework module. This vulnerability is fixed in 17.0.21.
Affected products
- Sangoma FreePBX: from 17.0.19.11 before 17.0.21 — fixed in 17.0.21
How to fix
Upgrade to a fixed version: Sangoma FreePBX 17.0.21. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-55211 or the next vulnerability affects your stack