What’s Vulnerable › Vulnerabilities
CVE-2025-5528: Social Sharing Plugin – Sassy Social Share <= 3.3.75 - Reflected Cross-Site Scripting via 'heateor_mastodon_share' Parameter
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The Social Sharing Plugin – Sassy Social Share plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the heateor_mastodon_share parameter in all versions up to, and including, 3.3.75 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action, such as clicking on a link.
Affected products
- heateor Social Sharing Plugin – Sassy Social Share: before 3.3.76 — fixed in 3.3.76
How to fix
Upgrade to a fixed version: heateor Social Sharing Plugin – Sassy Social Share 3.3.76. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/sassy-social-share/tags/3.3.75/public/class-sassy-social-share-public.php#L1481
- https://www.wordfence.com/threat-intel/vulnerabilities/id/99e922ec-d40a-47e7-a10f-d966a351d182?source=cve
Get alerted when CVE-2025-5528 or the next vulnerability affects your stack