What’s Vulnerable › Vulnerabilities
CVE-2025-55282: aiven-db-migrate allows Privilege Escalation via unrestricted search_path during migration
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-18 · updated 2026-06-17
- Weakness: CWE-22
Description
aiven-db-migrate is an Aiven database migration tool. Prior to 1.0.7, there is a privilege escalation vulnerability that allows a user to elevate to superuser inside PostgreSQL databases during a migration from an untrusted source server. By exploiting a lack of search_path restriction, an attacker can override pg_catalog and execute untrusted operators as a superuser. This vulnerability is fixed in 1.0.7.
Affected products
- aiven-db-migrate: before 1.0.7 — fixed in 1.0.7
How to fix
Upgrade to a fixed version: aiven-db-migrate 1.0.7. Check the vendor advisory for mitigations.
References
- https://github.com/aiven/aiven-db-migrate/commit/39517dc55720055d93262033b142a365f5bf92c5
- https://github.com/aiven/aiven-db-migrate/security/advisories/GHSA-hmvf-93r4-36f9
Get alerted when CVE-2025-55282 or the next vulnerability affects your stack