What’s Vulnerable › Vulnerabilities
CVE-2025-5530: WPC Smart Compare for WooCommerce <= 6.4.6 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The WPC Smart Compare for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'shortcode_btn' shortcode in all versions up to, and including, 6.4.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- wpclever WPC Smart Compare for WooCommerce: before 6.4.7 — fixed in 6.4.7
How to fix
Upgrade to a fixed version: wpclever WPC Smart Compare for WooCommerce 6.4.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/woo-smart-compare/tags/6.4.5/wpc-smart-compare.php#L187
- https://plugins.trac.wordpress.org/browser/woo-smart-compare/tags/6.4.5/wpc-smart-compare.php#L2616
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3318565%40woo-smart-compare&new=3318565%40woo-smart-compare&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3bd09891-8117-43b1-8744-8f3773971540?source=cve
Get alerted when CVE-2025-5530 or the next vulnerability affects your stack