What’s Vulnerable › Vulnerabilities

CVE-2025-55668: Apache Tomcat: session fixation via rewrite valve

Description

Session Fixation vulnerability in Apache Tomcat via rewrite valve. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0-M1 through 10.1.41, from 9.0.0.M1 through 9.0.105. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Tomcat 10.1.42, 11.0.8, 9.0.106. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-55668 or the next vulnerability affects your stack