What’s Vulnerable › Vulnerabilities
CVE-2025-5567: Shortcodes Ultimate <= 7.4.0 - Authenticted (Contributor+) Stored Cross-Site Scripting via 'data-url' Attribute
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Shortcodes Plugin — Shortcodes Ultimate plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'data-url' DOM element attribute in all versions up to, and including, 7.4.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- gn_themes WP Shortcodes Plugin — Shortcodes Ultimate: before 7.4.1 — fixed in 7.4.1
How to fix
Upgrade to a fixed version: gn_themes WP Shortcodes Plugin — Shortcodes Ultimate 7.4.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/shortcodes-ultimate/tags/7.4.0/includes/js/shortcodes/index.js
- https://www.wordfence.com/threat-intel/vulnerabilities/id/fbd67145-5b95-4890-a265-1dd7a029aec6?source=cve
Get alerted when CVE-2025-5567 or the next vulnerability affects your stack