What’s Vulnerable › Vulnerabilities
CVE-2025-55672: Apache Superset: Stored XSS on charts metadata
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-14 · updated 2026-06-17
- Weakness: CWE-80
Description
A stored Cross-Site Scripting (XSS) vulnerability exists in Apache Superset's chart visualization. An authenticated user with permissions to edit charts can inject a malicious payload into a column's label. The payload is not properly sanitized and gets executed in the victim's browser when they hover over the chart, potentially leading to session hijacking or the execution of arbitrary commands on behalf of the user. This issue affects Apache Superset: before 5.0.0. Users are recommended to upgrade to version 5.0.0, which fixes the issue.
Affected products
- Apache Superset: before 5.0.0 — fixed in 5.0.0
How to fix
Upgrade to a fixed version: Apache Superset 5.0.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/rvh7fdjfzxzjhcfwoz7twc2brhvochdj
- http://www.openwall.com/lists/oss-security/2025/08/14/4
Get alerted when CVE-2025-55672 or the next vulnerability affects your stack