What’s Vulnerable › Vulnerabilities
CVE-2025-55673: Apache Superset: Metadata exposure in embedded charts
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-14 · updated 2026-06-17
- Weakness: CWE-200
Description
When a guest user accesses a chart in Apache Superset, the API response from the /chart/data endpoint includes a query field in its payload. This field contains the underlying query, which improperly discloses database schema information, such as table names, to the low-privileged guest user. This issue affects Apache Superset: before 4.1.3. Users are recommended to upgrade to version 4.1.3, which fixes the issue.
Affected products
- Apache Superset: before 4.1.3 — fixed in 4.1.3
How to fix
Upgrade to a fixed version: Apache Superset 4.1.3. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/h2hw756wk4sj4z49blvzkr5fntl9hlf8
- http://www.openwall.com/lists/oss-security/2025/08/14/3
Get alerted when CVE-2025-55673 or the next vulnerability affects your stack