What’s Vulnerable › Vulnerabilities
CVE-2025-55674: Apache Superset: Improper SQL authorisation, parse not checking for specific engine functions
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-14 · updated 2026-06-17
- Weakness: CWE-89
Description
A bypass of the DISALLOWED_SQL_FUNCTIONS security feature in Apache Superset allows for the execution of blocked SQL functions. An attacker can use a special inline block to circumvent the denylist. This allows a user with SQL Lab access to execute functions that were intended to be disabled, leading to the disclosure of sensitive database information like the software version. This issue affects Apache Superset: before 5.0.0. Users are recommended to upgrade to version 5.0.0, which fixes the issue.
Affected products
- Apache Superset: before 5.0.0 — fixed in 5.0.0
How to fix
Upgrade to a fixed version: Apache Superset 5.0.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/cn49ps15ny3g2b1qzdg5mj7hp47p5jdo
- http://www.openwall.com/lists/oss-security/2025/08/14/5
Get alerted when CVE-2025-55674 or the next vulnerability affects your stack