What’s Vulnerable › Vulnerabilities
CVE-2025-55675: Apache Superset: Incorrect datasource authorization on REST API
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-14 · updated 2026-06-17
- Weakness: CWE-285
Description
Apache Superset contains an improper access control vulnerability in its /explore endpoint. A missing authorization check allows an authenticated user to discover metadata about datasources they do not have permission to access. By iterating through the datasource_id in the URL, an attacker can enumerate and confirm the existence and names of protected datasources, leading to sensitive information disclosure. This issue affects Apache Superset: before 5.0.0. Users are recommended to upgrade to version 5.0.0, which fixes the issue.
Affected products
- Apache Superset: before 5.0.0 — fixed in 5.0.0
How to fix
Upgrade to a fixed version: Apache Superset 5.0.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/op681b4kbd7g84tfjf9omz0sxggbcv33
- http://www.openwall.com/lists/oss-security/2025/08/14/6
Get alerted when CVE-2025-55675 or the next vulnerability affects your stack