What’s Vulnerable › Vulnerabilities
CVE-2025-55752: Apache Tomcat: Directory traversal via rewrite with possible RCE if PUT is enabled
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 64.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-27 · updated 2026-10-08
- Weakness: CWE-23
Description
Relative Path Traversal vulnerability in Apache Tomcat. The fix for bug 60013 introduced a regression where the rewritten URL was normalized before it was decoded. This introduced the possibility that, for rewrite rules that rewrite query parameters to the URL, an attacker could manipulate the request URI to bypass security constraints including the protection for /WEB-INF/ and /META-INF/. If PUT requests were also enabled then malicious files could be uploaded leading to remote code execution. PUT requests are normally limited to trusted users and it is considered unlikely that PUT requests would be enabled in conjunction with a rewrite that manipulated the URI. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.0.M11 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.6 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.
Affected products
- Apache Tomcat: from 8.5.6 through 8.5.100; from 9.0.1 before 9.0.109; from 10.0.0 before 10.0.27; from 10.1.0 before 10.1.45; from 11.0.0 before 11.0.11; 9.0.0, 9.0.0-milestone11, 9.0.0-milestone12, 9.0.0-milestone13, 9.0.0-milestone14, 9.0.0-milestone15 (+12) — fixed in 10.0.27, 10.1.45, 11.0.11, 9.0.109
How to fix
Upgrade to a fixed version: Apache Tomcat 10.0.27, 10.1.45, 11.0.11, 9.0.109. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/n05kjcwyj1s45ovs8ll1qrrojhfb1tog
- http://www.openwall.com/lists/oss-security/2025/10/27/4
- https://www.vicarius.io/vsociety/posts/cve-2025-55752-detect-apache-tomcat-vulnerability
- https://www.vicarius.io/vsociety/posts/cve-2025-55752-mitigate-apache-tomcat-vulnerability
- https://cert-portal.siemens.com/productcert/html/ssa-032379.html
Get alerted when CVE-2025-55752 or the next vulnerability affects your stack