What’s Vulnerable › Vulnerabilities
CVE-2025-55753: Apache HTTP Server: mod_md (ACME), unintended retry intervals
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-05 · updated 2026-10-18
- Weakness: CWE-190
Description
An integer overflow in the case of failed ACME certificate renewal leads, after a number of failures (~30 days in default configurations), to the backoff timer becoming 0. Attempts to renew the certificate then are repeated without delays until it succeeds. This issue affects Apache HTTP Server: from 2.4.30 before 2.4.66. Users are recommended to upgrade to version 2.4.66, which fixes the issue.
Affected products
- Apache HTTP Server: from 2.4.30 before 2.4.66 — fixed in 2.4.66
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.4.66. Check the vendor advisory for mitigations.
References
- https://httpd.apache.org/security/vulnerabilities_24.html
- http://www.openwall.com/lists/oss-security/2025/12/04/4
Get alerted when CVE-2025-55753 or the next vulnerability affects your stack