What’s Vulnerable › Vulnerabilities
CVE-2025-55754: Apache Tomcat: console manipulation via escape sequences in log messages
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-27 · updated 2026-10-08
- Weakness: CWE-150
Description
Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. Tomcat did not escape ANSI escape sequences in log messages. If Tomcat was running in a console on a Windows operating system, and the console supported ANSI escape sequences, it was possible for an attacker to use a specially crafted URL to inject ANSI escape sequences to manipulate the console and the clipboard and attempt to trick an administrator into running an attacker controlled command. While no attack vector was found, it may have been possible to mount this attack on other operating systems. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.40 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.60 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.
Affected products
- Apache Tomcat: from 8.5.60 through 8.5.100; from 9.0.40 before 9.0.109; from 10.0.0 before 10.0.27; from 10.1.0 before 10.1.45; from 11.0.0 before 11.0.11 — fixed in 10.0.27, 10.1.45, 11.0.11, 9.0.109
How to fix
Upgrade to a fixed version: Apache Tomcat 10.0.27, 10.1.45, 11.0.11, 9.0.109. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/j7w54hqbkfcn0xb9xy0wnx8w5nymcbqd
- http://www.openwall.com/lists/oss-security/2025/10/27/5
- https://cert-portal.siemens.com/productcert/html/ssa-032379.html
Get alerted when CVE-2025-55754 or the next vulnerability affects your stack