What’s Vulnerable › Vulnerabilities
CVE-2025-55795
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-29 · updated 2026-09-29
- Weakness: CWE-284
Description
The openml/openml.org web application version v2.0.20241110 uses incremental user IDs and insufficient email ownership verification during email update workflows. An authenticated attacker controlling a user account with a lower user ID can update their email address to that of another user with a higher user ID without proper verification. This results in the victim's email being reassigned to the attacker's account, causing the victim to be locked out immediately and unable to log in. The vulnerability leads to denial of service via account lockout but does not grant the attacker direct access to the victim's private data.
Affected products
- Openml Frontend: before 2.0.20251111 — fixed in 2.0.20251111
How to fix
Upgrade to a fixed version: Openml Frontend 2.0.20251111. Check the vendor advisory for mitigations.
References
- https://github.com/openml
- https://github.com/openml/openml.org
- https://github.com/openml/openml.org/security/advisories/GHSA-87c5-mc8v-xf7r
Get alerted when CVE-2025-55795 or the next vulnerability affects your stack