What’s Vulnerable › Vulnerabilities
CVE-2025-5585: SiteOrigin Widgets Bundle <= 1.68.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via `data-url` DOM Element Attribute
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The SiteOrigin Widgets Bundle plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `data-url` DOM Element Attribute in all versions up to, and including, 1.68.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- gpriday SiteOrigin Widgets Bundle: before 1.69.0 — fixed in 1.69.0
How to fix
Upgrade to a fixed version: gpriday SiteOrigin Widgets Bundle 1.69.0. Check the vendor advisory for mitigations.
References
- https://plugins.svn.wordpress.org/so-widgets-bundle/tags/1.68.4/js/slider/jquery.slider.js
- https://www.wordfence.com/threat-intel/vulnerabilities/id/bb1b93ee-8641-4ddb-8b6b-2e9d30fe338d?source=cve
Get alerted when CVE-2025-5585 or the next vulnerability affects your stack