What’s Vulnerable › Vulnerabilities
CVE-2025-55904
- Severity: medium (CVSS 4.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-17 · updated 2026-06-17
- Weakness: CWE-476
Description
Open5GS v2.7.5, prior to commit 67ba7f92bbd7a378954895d96d9d7b05d5b64615, is vulnerable to a NULL pointer dereference when a multipart/related HTTP POST request with an empty HTTP body is sent to the SBI of either AMF, AUSF, BSF, NRF, NSSF, PCF, SMF, UDM, or UDR, resulting in a denial of service. This occurs in the parse_multipart function in lib/sbi/message.c.
Affected products
- Open5GS: before 2.7.6 — fixed in 2.7.6
How to fix
Upgrade to a fixed version: Open5GS 2.7.6. Check the vendor advisory for mitigations.
References
- https://github.com/open5gs/open5gs/commit/67ba7f92bbd7a378954895d96d9d7b05d5b64615
- https://github.com/open5gs/open5gs/issues/3942
- https://github.com/tsiamoulis/vuln-research/tree/main/CVE-2025-55904
Get alerted when CVE-2025-55904 or the next vulnerability affects your stack