What’s Vulnerable › Vulnerabilities
CVE-2025-56007
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-23 · updated 2026-06-17
- Weakness: CWE-93
Description
CRLF-injection in KeeneticOS before 4.3 at "/auth" API endpoint allows attackers to take over the device via adding additional users with full permissions by managing the victim to open page with exploit.
Affected products
- Keeneticos: before 4.3 — fixed in 4.3
How to fix
Upgrade to a fixed version: Keeneticos 4.3. Check the vendor advisory for mitigations.
References
- https://github.com/notdenied/writeups/blob/main/CVE/CVE-2025-56007.md
- https://keenetic.com/
- https://keenetic.com/global/security#october-2025-web-api-vulnerabilities
Get alerted when CVE-2025-56007 or the next vulnerability affects your stack