What’s Vulnerable › Vulnerabilities
CVE-2025-5601: Buffer Copy without Checking Size of Input ('Classic Buffer Overflow') in Wireshark
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-04 · updated 2026-06-17
- Weakness: CWE-120
Description
Column handling crashes in Wireshark 4.4.0 to 4.4.6 and 4.2.0 to 4.2.12 allows denial of service via packet injection or crafted capture file
Affected products
- Wireshark Foundation Wireshark: from 4.2.0 before 4.2.12; from 4.4.0 before 4.4.7 — fixed in 4.2.12, 4.4.7
How to fix
Upgrade to a fixed version: Wireshark Foundation Wireshark 4.2.12, 4.4.7. Check the vendor advisory for mitigations.
References
- https://gitlab.com/wireshark/wireshark/-/issues/20509
- https://www.wireshark.org/security/wnpa-sec-2025-02.html
Get alerted when CVE-2025-5601 or the next vulnerability affects your stack