What’s Vulnerable › Vulnerabilities
CVE-2025-56333
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-29 · updated 2026-10-13
- Weakness: CWE-287
Description
An issue in Fossorial fosrl/pangolin v.1.6.2 and before allows a remote attacker to escalate privileges via the 2FA component
Affected products
- Pangolin: before 1.7.0 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: Pangolin 1.7.0. Check the vendor advisory for mitigations.
References
- https://gist.github.com/mrdgef/ef6fa41d69c0457874414c163d7d7d75
- https://github.com/fosrl/pangolin
- https://gist.github.com/mrdgef/ef6fa41d69c0457874414c163d7d7d75
Get alerted when CVE-2025-56333 or the next vulnerability affects your stack