What’s Vulnerable › Vulnerabilities
CVE-2025-56534
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-29 · updated 2026-10-15
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability in the custom authenticator driver of opennebula v6.10.0.1 allows attackers to execute arbitrary web scripts or HTML via a crafted payload.
Affected products
- OpenNebula: before 7.0.0 — fixed in 7.0.0
How to fix
Upgrade to a fixed version: OpenNebula 7.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/MarkArtamonov/OpenNebula-CVE-2025-56534
- https://opennebula.io/opennebula-7/
- https://github.com/MarkArtamonov/OpenNebula-CVE-2025-56534
Get alerted when CVE-2025-56534 or the next vulnerability affects your stack