What’s Vulnerable › Vulnerabilities

CVE-2025-5662: Deserialization Vulnerability in h2oai/h2o-3

Description

A deserialization vulnerability exists in the H2O-3 REST API (POST /99/ImportSQLTable) that affects all versions up to 3.46.0.7. This vulnerability allows remote code execution (RCE) due to improper validation of JDBC connection parameters when using a Key-Value format. The vulnerability is present in the MySQL JDBC Driver version 8.0.19 and JDK version 8u112. The issue is resolved in version 3.46.0.8.

Affected products

How to fix

Upgrade to a fixed version: h2oai/h2o-3 3.46.0.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-5662 or the next vulnerability affects your stack